MT RSync Not Working

mailtonzj's Avatar

mailtonzj

24 Feb, 2011 12:14 PM

First of all, thank you for the very helpful page on rsync for MT. I've got the setup to work, including making sure that the test command works. However, with the following settings in my mt-config.cgi file, nothing happened after I initiated a entry publish.

SyncTarget [target ip address]:/
RsyncOptions -auzq -e ssh

May I know where I could look around to kick start the troubleshooting process? I'm running MT 4.35. Thank you!

  1. Support Staff 1 Posted by Byrne Reese on 24 Feb, 2011 08:00 PM

    Byrne Reese's Avatar

    Thank you for contacting us. Testing rsync running within the context of Movable Type can be a little challenging I admit, because Movable Type tends to swallow a lot of useful output. There are a couple things I can recommend though that will help bring these messages to the surface.

    1) Turn on DebugMode. Set the config directive's value to 4 (at least). Consult the documentation online to learn more about DebugMode.

    2) David Raynes has an exceptional plugin, which will hopefully become core to Melody one day, called Task Master. It is free and allows you to invoke a task normally run via run-periodic-tasks on demand. This allows you to trigger and re-trigger an event so that you can more easily monitor its performance and its output.

    3) Make sure that in your tests you invoke rync using the same user under which the crontab is being run. Make sure you test that the user and the remote user all have access to run the commands specified. If you can provide us with the output from your test commands, that will be helpful as well.

  2. 2 Posted by mailtonzj on 25 Feb, 2011 12:16 PM

    mailtonzj's Avatar

    Hi Byrne, thank you for your reply. It means a lot as I feel it's difficult to find technical help for MT.

    I've enabled DebugMode to 4 but am not sure where to look for the log files.

    I installed Task Master as you've recommended. Got it to list down the periodic tasks and here they are:

    AddSummaryWatcher:
    Label: Add Summary Watcher to queue
    Frequency: 2m
    Component: Core
    CleanTemporaryFiles:
    Label: Remove Temporary Files
    Frequency: 1h
    Component: Core
    FuturePost:
    Label: Publish Scheduled Entries
    Frequency: 1m
    Component: Core
    JunkExpiration:
    Label: Junk Folder Expiration
    Frequency: 12h
    Component: Core
    RemoveExpiredSearchCaches:
    Label: Remove Expired Search Caches
    Frequency: 1d
    Component: Core
    RemoveExpiredUserSessions:
    Label: Remove Expired User Sessions
    Frequency: 1d
    Component: Core
    UpdateEvents:
    Label: Poll for new events
    Frequency: 30m
    Component: Action Streams`
    

    Not sure which task I should be re-activating for MT to kick start the rsync process though. I understand that rsync is suppose to follow right after a Publish Queue activity?

    Lastly, I am running the publish queue with run-periodic-tasks as a daemon process as the user root. So I believe MT shouldn't be a access rights issue. The test command that I issued (as root) was

    scp /var/www/html/qc3/index.php www.domainname.com:/var/www/html/qc3/index.php

    (I have configured ssh_config such that username and passkey will be given automatically for troubleshooting purpose.) The response was a very simple

    index.php 100% 2525 2.5KB/s 00:00

    Let me know if the information I've provide is sufficient. Once again, thank you for your assistance. :)

  3. Support Staff 3 Posted by Byrne Reese on 25 Feb, 2011 07:46 PM

    Byrne Reese's Avatar

    Well it seems you are doing the right thing. But it is a little hard to tell to be honest. The only thing I see you are going different than the documentation are the options you are using for rsync. Have you tried a different set of options, or the more minimal set as specified by the documentation?

    Also, you might consider adding a logfile option to rsync. That might give you more information to help you troubleshoot.

  4. 4 Posted by mailtonzj on 25 Feb, 2011 08:52 PM

    mailtonzj's Avatar

    I have further simplified the mt-config.cgi configuration to

    SyncTarget someserver.com:/
    RsyncOptions -e ssh
    

    but I'm still not seeing any rsync activity.

    My gut tells me that the rsync session wasn't initiated. Otherwise we should be seeing some records in the activity log with DebugMode enabled. Speaking of which, where could I see the outputs from DebugMode? I can't find any MT-related records in /var/log

  5. Support Staff 5 Posted by Byrne Reese on 25 Feb, 2011 09:15 PM

    Byrne Reese's Avatar

    Ok - I think I might have an idea... Are you publishing any of your templates via Publish Queue? That is required in order for rsync to work properly.

  6. 6 Posted by mailtonzj on 26 Feb, 2011 03:32 AM

    mailtonzj's Avatar

    Yep, all my templates are published via Publish Queue.

  7. Support Staff 7 Posted by Jay Allen on 30 Nov, 2011 07:12 PM

    Jay Allen's Avatar

    Hi mailtonzj. Please accept our apologies for not responding until now. I'm going through the system looking for straggler posts like this one and wanted to know if this issue is still relevant for you. If so, please let me know so I can bump it up on our radar.

    Once again, sorry to have dropped the ball. We aim to do better in the future.

    Jay Allen
    Principal, Endevver LLC

  8. 8 Posted by mailtonzj on 01 Dec, 2011 03:50 AM

    mailtonzj's Avatar

    I couldn't get MT RSync to work and so I am using an external process
    called Unison to handle the synchronization. So the problem is fixed. :)

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac