ImageCropper issue

tom_keating's Avatar

tom_keating

03 Sep, 2010 04:01 PM

I forgot to copy the extlib/ folder and launched the MT upgrade process kicked off by the new plugin.

After the fact I did copy the extlib/ folder. Not sure if that was needed during the install process. I didn't see an error during the upgrade. In any event, my Activity log is showing this error below. And when I try and click Thumbnail Protoypes in the menu option I get an error message with a blank yellow rectangular box.

you can check my modules here:
http://blog.tmcnet.com/mt/mt-check.cgi

only Perl module I don't have is IPC::Run, but I think that's used for NetPBM.

Also, I'm running ImageMagick 6.2.8.
Ideas?

Image Cropper died with: failed loading package ImageCropper::Plugin for routine ImageCropper::Plugin::init_app: syntax error at /var/www/cgi-bin/mt/plugins/ImageCropper/lib/ ImageCropper/Plugin.pm line 164, near "->id my " Global symbol "$ts" requires explicit package name at /var/www/cgi-bin/mt/plugins/ImageCropper/lib/ ImageCropper/Plugin.pm line 164. Compilation failed in require at /var/www/cgi-bin/mt/lib/MT.pm line 2946. at /var/www/cgi-bin/mt/lib/MT.pm line 2946 MT::handler_to_coderef('MT', '$ImageCropper::ImageCropper::Plugin::init_ap p') called at /var/www/cgi-bin/mt/lib/MT/Callback.pm line 32 MT::Callback::invoke('MT::Callback=HASH(0x175 023c0)', 'MT::App::CMS=HASH(0x15131800)', 'App', 'MT::App::CMS') called at /var/www/cgi-bin/mt/lib/MT.pm line 639 eval {...} called at /var/www/cgi-bin/mt/lib/MT.pm line 637 MT::run_callback('MT::App::CMS=HASH(0x1513180 0)', 'MT::Callback=HASH(0x175023c0)', 'MT::App::CMS=HASH(0x15131800)', 'App', 'MT::App::CMS') called at /var/www/cgi-bin/mt/lib/MT.pm line 730 MT::run_callbacks('MT::App::CMS=HASH(0x151318 00)', 'MT::App::CMS::init_app', 'MT::App::CMS=HASH(0x15131800)', 'App', 'MT::App::CMS') called at /var/www/cgi-bin/mt/lib/MT/App.pm line 694 MT::App::run_callbacks('MT::App::CMS=HASH(0x1 5131800)', 'init_app', 'MT::App::CMS=HASH(0x15131800)', 'App', 'MT::App::CMS') called at /var/www/cgi-bin/mt/lib/MT/App.pm line 654 MT::App::init('MT::App::CMS=HASH(0x15131800)' , 'App', 'MT::App::CMS') called at /var/www/cgi-bin/mt/lib/MT/App/CMS.pm line 24 MT::App::CMS::init('MT::App::CMS=HASH(0x15131 800)', 'App', 'MT::App::CMS') called at /var/www/cgi-bin/mt/lib/MT.pm line 275 MT::construct('MT::App::CMS', 'App', 'MT::App::CMS') called at /var/www/cgi-bin/mt/lib/MT.pm line 268 MT::instance_of called at /var/www/cgi-bin/mt/lib/MT.pm line 261 MT::new('MT::App::CMS', 'App', 'MT::App::CMS') called at /var/www/cgi-bin/mt/lib/MT/Bootstrap.pm line 133 eval {...} called at /var/www/cgi-bin/mt/lib/MT/Bootstrap.pm line 76 MT::Bootstrap::import('MT::Bootstrap', 'App', 'MT::App::CMS') called at /var/www/cgi-bin/mt/mt.cgi line 11 main::BEGIN() called at /var/www/cgi-bin/mt/lib/MT.pm line 11 eval {...} called at /var/www/cgi-bin/mt/lib/MT.pm line 11
  1. Support Staff 1 Posted by Jay Allen on 30 Nov, 2011 07:17 PM

    Jay Allen's Avatar

    Hi Tom. Please accept our apologies for not responding until now. I'm going through the system looking for straggler posts like this one and wanted to know if this issue is still relevant for you. If so, please let me know (AND what version of ImageCropper you have if not the latest, 1.0.24) so I can bump it up on our radar. Also if you're not running the latest, you may want to upgrade first in case the issue has been fixed (which is likely given the error).

    Once again, sorry to have dropped the ball. We aim to do better in the future.

    Jay Allen
    Principal, Endevver LLC

  2. 2 Posted by tom_keating on 01 Dec, 2011 03:08 PM

    tom_keating's Avatar

    Hi Jay,

    This issue was a while ago, so I’m going from my notes. But I do recall that I wasn’t able to select one of the thumbnail prototypes. Figured out the problem was a jquery conflict.

    Here’s my exact note in my personal KB:

    Fixed Image Cropper plugin by removing jquery.js conflict from /var/www/html/mt-static/plugins/FeaturedAssets/js/ folder. don't leave jquery.js in this folder or this plugin will load jquery that conflicts with ImageCropper thumbnail generation. Can't pick one of the thumbnail prototypes.

    So I think I’m good, but worth documenting on your end perhaps.

    Tom Keating / TMC Labs
    VP & CTO & SEO Director & Executive Technology Editor
    My blog, covering VoIP news, telecom, gadgets:
    http://blog.tmcnet.com/blog/tom-keating/

    Meet me on LinkedIn<http://www.linkedin.com/pub/9/b07/b7> or Facebook<http://www.facebook.com/profile.php?id=743068622> or Twitter<http://twitter.com/tomkeating>

    TMCnet.com<http://www.tmcnet.com/> - serving over 3,000,000 unique visitors per month!

    203-852-6800 x149

    TMC
    800 Connecticut Ave
    1st Floor East
    Norwalk, CT 06854

    INTERNET TELEPHONY Conference & EXPO - www.itexpo.com<http://www.itexpo.com/>
    East 2012: February 1-3, 2012 — Miami, FL
    West 2011: October 4-6, 2012 — Austin, Texas

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac